dnes je 6.7.2022

Input:

Excel 2013: Maticové výpočty

15.1.2014, , Zdroj: Verlag Dashöfer

Používání maticových vzorců není mezi uživateli Excelu příliš rozšířeno. Přitom jejich využití umožňuje efektivně zpracovávat velké množství údajů. Zaměřme se proto alespoň na základní seznámení s těmito vzorci.

Podstatou maticových vzorců je schopnost nahradit velký počet jednotlivých vzorců vzorcem jediným. Jejich pomocí lze řešit úlohy, které jsou jinými prostředky prakticky neřešitelné. Vybrané případy si ukážeme na několika příkladech.

Zásady práce s maticovými vzorci

  • V jednom argumentu maticového vzorce nelze kombinovat matice s různým počtem řádků a/nebo sloupců.
  • Maticový vzorec zadáváte pomocí Ctrl+Shift+Enter (nemůžete vkládat složené závorky {} pomocí klávesnice, jsou automaticky doplněny okolo vzorce po stisku této kombinace kláves).
  • Nelze změnit jen některé z buněk obsahující maticový vzorec, pokud jeho výsledkem je opět matice.

Výpočet vyplacených mezd

Zajímá vás celkový objem mezd podle dat v následující tabulce:

 Přehled mezd

Většina uživatelů by v tabulce do nového (pomocného) sloupce vložila vzorec pro vynásobení odpracovaných hodin a hodinové mzdy a výsledky sečetla.

Tomuto postupnému výpočtu se lze vyhnout tak, že vytvoříte jediný – maticový vzorec, který spočítá dílčí součiny a pak je i sečte. Tento vzorec bude (v buňce C9) vypadat následovně: {=SUMA(B2:B7*C2:C7)}. Uvedený vzorec sečte součin odpovídajících buněk v oblastech B2:B7 a C2:C7.

Zápis tohoto maticového vzorce provedete následovně:

  • Do buňky C9 zapište =SUMA(B2:B7*C2:C7)
  • Stiskněte Ctrl+Shift+Enter

Pokud by vás zajímaly podrobnosti provedeného výpočtu, můžete použít režim částečného výpočtu, který spustíte pomocí klávesy F9. Ve vzorci, který jste vytvořili, chcete znát podrobnosti o údajích v závorce: označte tuto závorku v řádku vzorců a stiskněte klávesu F9.

V závorce se nyní zobrazily dílčí hodnoty (výsledky součinů A2*B2 , A3*B3 , A4*B4 , A5*B5 , A6*B6 , A7*B7,

Nahrávám...
Nahrávám...