dnes je 6.7.2022

Input:

Excel 2007: Makra - Praktická ukázka - 11. část

16.9.2010, , Zdroj: Verlag Dashöfer

Sestavíme makro, které naše vypsané nezaplacené pohledávky rozčlení do skupin podle počtu dní, které uplynuly od data splatnosti – tedy 30, 60, 90 dní, nad 90 dní.

Makro tedy musí upravit naši tabulku, aby vypadala takto:

Půjde tedy o doplnění sloupců G až J, kam makro zapíše nadpisy sloupců a vyplní vzorečky, které vypíší částky pohledávek podle toho, kolik dní je uvedeno ve sloupci Po splatnosti.

Začneme tedy se záznamem makra (Vývojář-Kód-Záznam makra), které si uložíme opět do našeho rozpracovaného sešitu pod názvem rozdeleni_pohledavek.

1. V sešitě přepneme na list Nezaplacene.

2. Klávesovou zkratkou CTRL+Home přemístíme kurzor na buňku A1.

3. V nabídce Vývojář – Kód – zapneme příkaz Použít relativní odkazy.

4. Posuneme kurzor pomocí kurzorové klávesy do buňky F1 – to je prázdný sloupec s nadpisem Zaplaceno. Tento sloupec odstraníme – použijeme pravé tlačítko myši a z místní nabídky potvrdíme příkaz Odstranit, v dialogovém okně nastavíme volbu Celý sloupec a potvrdíme tlačítkem OK.

5. Kurzor posuneme pomocí kurzorové klávesy o jednu pozici doprava pomocí kurzorové šipky, je tedy nyní umístěn na buňce G1. Sem napíšeme nadpis „Do 30 dnů“.

6. Dále posuneme kurzor opět kurzorovou klávesou, tentokrát o jednu buňku dolů.

7. V řádku vzorců stiskneme ikonu Fx pro vyvolání dialogového okna Vložit funkci a v buňce sestavíme vzorec - =KDYŽ(A(F2>0;F2<31);C2;““).

8. Vzorec zkopírujeme pomocí CTRL+C.

9. Kurzor přesuneme na vedlejší buňku do leva (buňku F2) a pomocí klávesové kombinace CTRL+SHIFt+END provedeme označení sloupce F až do konce tabulky.

10.

Nahrávám...
Nahrávám...